Point to Point Ethernet Over MPLS with Cisco ME3600X, ME3800X and ASR 1000 series

Amaç :

Point-to-Point Ethernet Over MPLS için interface konfiglerini, Cisco EVC Frame Work veya klasik subinterface methodları arasındaki kullanım farklarını ve Custemer Paketlerinin (Vlan’lı veya Vlan’sız) taşınmasını anlamak.

İlk olarak EVC Frame work ve Point-to-Point MPLS L2VPN konfigurasyonu ve çalışma şeklini anlamak üzerine iki adet Cisco ASR 1002 arka arkaya bağlımak sureti ile test’ler planlanmıştır.

Daha sonra Cisco ME-3600 switch kullanılarak uygulamalar incelenmiştir.

Customer Vlan’ın taşınması sırasında L2 QoS bilgisinin, cos bit’i, taşınmasına gösterilmiştir.

Testler sırasında Cisco EVC frame work kullanımı ve normal subinterface yöntemi ile olan farklığınu gösterilmiştir.

Ayrıca control word bilgisinin pseudowire üzerindeki etkisi incelenmiştir.

ASR 1000 için ;

Ana inteface altında kurulan xconnectler default’da type 5 olarak kurulur ve vlan bilgisini iletir.

Subinterface altında kurulan xconnectler defualt’da type 4 olarak konfigure edilir ve vlan bilgisini iletmez. Fakat pw-class kullanarak interworking vlan yapılır ise vlan bilgisinin iletilmesi sağlanabilir.

EVC konfiği ile kurulan xconnectler default olarak type 4 kurulur ve vlan bilgisini iletir. Eğer rewrite komutu ile bir silme veya ekleme işlemi yapılmış ise buna göre davranılır.

Dolayısı ile EVC ve subint kullanmanın farklı vlan bilgisinin iletilip iletilmeyeceğini belirler.

  • Mümkün olduğunca aggeragation noktalarında PE interfacelerinde EVC frame work kullanılmalıdır. ASR1K ve ASR9K serisinde EVC kullanımı desteklenmektedir.
  • S-Vlan bilgisi pseudowire üzerinden iletilmelidir.
  • Pseudowire kullanımında MPLS exp biti ile paketler uygun backbone qos sınıfına sokulmalıdır.
  • Control Word kullanımı sadece ilk vlag tag’in taşıma şeklini belirler.
  • Her test için packet capture alınmıştır.

Genel Testler :

Genel Topology  :

Genel Toplogy
Genel Toplogy

Test 1 Ethernet Vlan – Subinterface :

Konfigurasyonlar :

PE -2 :

interface GigabitEthernet0/0/1

mtu 9216

no ip address

negotiation auto

cdp enable

!

interface GigabitEthernet0/0/1.50

encapsulation dot1Q 50

xconnect 1.1.1.1.7 4 encapsulation mpls

!

interface GigabitEthernet0/0/2

no ip address

negotiation auto

cdp enable

!

interface GigabitEthernet0/0/2.50

encapsulation dot1Q 50 second-dot1q 200

ip vrf forwarding test

ip address 5.5.5.2 255.255.255.0

!

PE-3 :

interface GigabitEthernet0/0/1

mtu 9216

no ip address

negotiation auto

!

interface GigabitEthernet0/0/1.50

encapsulation dot1Q 50

xconnect 1.1.1.1.6 4 encapsulation mpls

!

interface GigabitEthernet0/0/2

no ip address

negotiation auto

!

interface GigabitEthernet0/0/2.50

encapsulation dot1Q 50 second-dot1q 200

ip vrf forwarding test

ip address 5.5.5.3 255.255.255.0

service-policy output mark-out

!

PE-3#ping vrf test 5.5.5.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 5.5.5.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

 

Kontroller :

PE-2#show mpls l2transport vc detail

Local interface: Gi0/0/1.50 up, line protocol up, Eth VLAN 50 up

Interworking type is Ethernet

Destination address: 1.1.1.1.7, VC ID: 4, VC status: up

Output interface: Gi0/0/0, imposed label stack {21}

Preferred path: not configured

Default path: active

Next hop: 10.177.183.3

Create time: 00:00:06, last status change time: 00:00:06

Last label FSM state change time: 00:00:06

Signaling protocol: LDP, peer 1.1.1.1.7:0 up

Targeted Hello: 1.1.1.1.6(LDP Id) -> 1.1.1.1.7, LDP is UP

Status TLV support (local/remote)   : enabled/supported

LDP route watch                   : enabled

Label/status state machine        : established, LruRru

Last local dataplane   status rcvd: No fault

Last BFD dataplane     status rcvd: Not sent

Last BFD peer monitor  status rcvd: No fault

Last local AC  circuit status rcvd: No fault

Last local AC  circuit status sent: No fault

Last local PW i/f circ status rcvd: No fault

Last local LDP TLV     status sent: No fault

Last remote LDP TLV    status rcvd: No fault

Last remote LDP ADJ    status rcvd: No fault

MPLS VC labels: local 46, remote 21

Group ID: local 0, remote 0

MTU: local 9216, remote 9216

Remote interface description:

Sequencing: receive disabled, send disabled

Control Word: On (configured: autosense)

SSO Descriptor: 1.1.1.1.7/4, local label: 46

Dataplane:

SSM segment/switch IDs: 4363/4362 (used), PWID: 4

VC statistics:

transit packet totals: receive 0, send 0

transit byte totals:   receive 0, send 0

transit packet drops:  receive 0, seq error 0, send 0

 

PE-3#show mpls l2transport vc detail

Local interface: Gi0/0/1.50 up, line protocol up, Eth VLAN 50 up

Destination address: 1.1.1.1.6, VC ID: 4, VC status: down

Output interface: none, imposed label stack {}

Preferred path: not configured

Default path: no route

No adjacency

Create time: 00:00:14, last status change time: 00:00:14

Signaling protocol: LDP, peer 1.1.1.1.6:0 up

Targeted Hello: 1.1.1.1.7(LDP Id) -> 1.1.1.1.6, LDP is DOWN, no binding

Status TLV support (local/remote)   : enabled/None (no remote binding)

LDP route watch                   : enabled

Label/status state machine        : local ready, LruRnd

Last local dataplane   status rcvd: No fault

Last BFD dataplane     status rcvd: Not sent

Last local SSS circuit status rcvd: No fault

Last local SSS circuit status sent: Not sent

Last local  LDP TLV    status sent: No fault

Last remote LDP TLV    status rcvd: None (no remote binding)

Last remote LDP ADJ    status rcvd: None (no remote binding)

MPLS VC labels: local 21, remote unassigned

PWID: 4170

Group ID: local 0, remote unknown

MTU: local 9216, remote unknown

Remote interface description:

Sequencing: receive disabled, send disabled

Control Word: On (configured: autosense)

VC statistics:

transit packet totals: receive 0, send 0

transit byte totals:   receive 0, send 0

transit packet drops:  receive 0, seq error 0, send 0

 

 

Sonuç :

C-Vlan bilgisi taşınıyor. Dolayısı ile CoS değeride transparent olarak taşınıyor. C-Vlan başlık bilgisi karşıya iletiliyor. S-Vlan bilgisi karşıya taşınmıyor dolayısı ile iki uçda hangi S-Vlanların kullanıldığının bir önemi yok.

 

Test 2 Ethernet Vlan Mode Control Word Off :

Test 1’deki topology kullanlıyor. Fakat kontrol word off olarak negotiate etmek için pseudowire-class kullanılarak control word off yapılıyor. Tek taraflı kapamak yeterli.

 

Konfigurasyon :

PE-3 :

!

pseudowire-class test

encapsulation mpls

 no control-word

!

interface GigabitEthernet0/0/1

mtu 9216

no ip address

negotiation auto

!

interface GigabitEthernet0/0/1.50

encapsulation dot1Q 50

xconnect 1.1.1.1.6 4 encapsulation mpls pw-class test

!

 

Kontrol :

PE-3#show mpls l2transport vc detail

Local interface: Gi0/0/1.50 up, line protocol up, Eth VLAN 50 up

Destination address: 1.1.1.1.6, VC ID: 4, VC status: up

Output interface: Gi0/0/0, imposed label stack {61}

Preferred path: not configured

Default path: active

Next hop: 10.177.183.2

Create time: 00:00:10, last status change time: 00:00:05

Signaling protocol: LDP, peer 1.1.1.1.6:0 up

Targeted Hello: 1.1.1.1.7(LDP Id) -> 1.1.1.1.6, LDP is UP

Status TLV support (local/remote)   : enabled/supported

LDP route watch                   : enabled

Label/status state machine        : established, LruRru

Last local dataplane   status rcvd: No fault

Last BFD dataplane     status rcvd: Not sent

Last local SSS circuit status rcvd: No fault

Last local SSS circuit status sent: No fault

Last local  LDP TLV    status sent: No fault

Last remote LDP TLV    status rcvd: No fault

Last remote LDP ADJ    status rcvd: No fault

MPLS VC labels: local 18, remote 61

PWID: 4185

Group ID: local 0, remote 0

MTU: local 9216, remote 9216

Remote interface description:

Sequencing: receive disabled, send disabled

  Control Word: Off

VC statistics:

transit packet totals: receive 0, send 0

transit byte totals:   receive 0, send 0

transit packet drops:  receive 0, seq error 0, send 0

 

Daha sonra tekrar control word on yapıldı. Bunun için iki taraflı interface’ler kapatılıp açıldı.

Packet capture içerisinde iki bilgide görülmektedir.

 

Sonuç:

Burada önemli olan control word bilgisidir. Control word kullanılıp kullanılmadığına göre vlan bilgisinin iletim methodu değişiyor. Eğer control word on olarak devre kurulmuş ise vlan header’ı olduğu gibi değişiyor. Eğer off olarak devre kurulmuş ise source ve destination mac addresleri kullanılarak vlan headarı olmadan bilgi iletiliyor. Source mac adresinin son iki hexadecimal bilgisi Vlan bilgisini içeriyor. Sondan  3. Hexadecimal bilgisin ilk 3 biti ise cos bilgisini içeriyior. Diğer alanlarda bir şekilde kullanılıyordur. 5-8 hexadecimal bilgisi ethertype belirtiyor.

 

Test 3  Ethernet Port Mod :

Control word on ve off olarak test edilmiştir.

Konfigurasyon :

PE-2:

!

interface GigabitEthernet0/0/1

mtu 9216

no ip address

negotiation auto

cdp enable

xconnect 1.1.1.1.7 4 encapsulation mpls

!

PE-3:

!

pseudowire-class test

encapsulation mpls

!

interface GigabitEthernet0/0/1

mtu 9216

no ip address

negotiation auto

xconnect 1.1.1.1.6 4 encapsulation mpls pw-class test

!

Kontrol :

PE-3#show mpls l2transport vc detail

Local interface: Gi0/0/1 up, line protocol up, Ethernet up

Destination address: 1.1.1.1.6, VC ID: 4, VC status: up

Output interface: Gi0/0/0, imposed label stack {51}

Preferred path: not configured

Default path: active

Next hop: 10.177.183.2

Create time: 00:11:07, last status change time: 00:11:07

Last label FSM state change time: 00:11:07

Signaling protocol: LDP, peer 1.1.1.1.6:0 up

Targeted Hello: 1.1.1.1.7(LDP Id) -> 1.1.1.1.6, LDP is UP

Status TLV support (local/remote)   : enabled/supported

LDP route watch                   : enabled

Label/status state machine        : established, LruRru

Last local dataplane   status rcvd: No fault

Last BFD dataplane     status rcvd: Not sent

Last BFD peer monitor  status rcvd: No fault

Last local AC  circuit status rcvd: No fault

Last local AC  circuit status sent: No fault

Last local PW i/f circ status rcvd: No fault

Last local LDP TLV     status sent: No fault

Last remote LDP TLV    status rcvd: No fault

Last remote LDP ADJ    status rcvd: No fault

MPLS VC labels: local 19, remote 51

Group ID: local 0, remote 0

MTU: local 9216, remote 9216

Remote interface description:

Sequencing: receive disabled, send disabled

Control Word: On (configured: autosense)

SSO Descriptor: 1.1.1.1.6/4, local label: 19

Dataplane:

SSM segment/switch IDs: 4112/4111 (used), PWID: 1

VC statistics:

transit packet totals: receive 13, send 1

transit byte totals:   receive 4589, send 99

transit packet drops:  receive 0, seq error 0, send 0

!

 

PE-2#show mpls l2transport vc detail

Local interface: Gi0/0/1 up, line protocol up, Ethernet up

Destination address: 1.1.1.1.7, VC ID: 4, VC status: up

Output interface: Gi0/0/0, imposed label stack {19}

Preferred path: not configured

Default path: active

Next hop: 10.177.183.3

Create time: 00:45:53, last status change time: 00:11:27

Last label FSM state change time: 00:11:27

Last peer autosense occurred at: 00:43:35

Signaling protocol: LDP, peer 1.1.1.1.7:0 up

Targeted Hello: 1.1.1.1.6(LDP Id) -> 1.1.1.1.7, LDP is UP

Status TLV support (local/remote)   : enabled/supported

LDP route watch                   : enabled

Label/status state machine        : established, LruRru

Last local dataplane   status rcvd: No fault

Last BFD dataplane     status rcvd: Not sent

Last BFD peer monitor  status rcvd: No fault

Last local AC  circuit status rcvd: No fault

Last local AC  circuit status sent: No fault

Last local PW i/f circ status rcvd: No fault

Last local LDP TLV     status sent: No fault

Last remote LDP TLV    status rcvd: No fault

Last remote LDP ADJ    status rcvd: No fault

MPLS VC labels: local 51, remote 19

Group ID: local 0, remote 0

MTU: local 9216, remote 9216

Remote interface description:

Sequencing: receive disabled, send disabled

Control Word: On (configured: autosense)

SSO Descriptor: 1.1.1.1.7/4, local label: 51

Dataplane:

SSM segment/switch IDs: 4422/4416 (used), PWID: 5

VC statistics:

transit packet totals: receive 16, send 65

transit byte totals:   receive 1540, send 21218

transit packet drops:  receive 0, seq error 0, send 0

 

 

PE-3 : control word off

!

pseudowire-class test

 encapsulation mpls

 no control-word

!

PE-3#show mpls l2transport vc detail

Local interface: Gi0/0/1 up, line protocol up, Ethernet up

Destination address: 1.1.1.1.6, VC ID: 4, VC status: up

Output interface: Gi0/0/0, imposed label stack {50}

Preferred path: not configured

Default path: active

Next hop: 10.177.183.2

Create time: 00:01:17, last status change time: 00:00:55

Last label FSM state change time: 00:00:55

Last peer autosense occurred at: 00:01:01

Signaling protocol: LDP, peer 1.1.1.1.6:0 up

Targeted Hello: 1.1.1.1.7(LDP Id) -> 1.1.1.1.6, LDP is UP

Status TLV support (local/remote)   : enabled/supported

LDP route watch                   : enabled

Label/status state machine        : established, LruRru

Last local dataplane   status rcvd: No fault

Last BFD dataplane     status rcvd: Not sent

Last BFD peer monitor  status rcvd: No fault

Last local AC  circuit status rcvd: No fault

Last local AC  circuit status sent: No fault

Last local PW i/f circ status rcvd: No fault

Last local LDP TLV     status sent: No fault

Last remote LDP TLV    status rcvd: No fault

Last remote LDP ADJ    status rcvd: No fault

MPLS VC labels: local 23, remote 50

Group ID: local 0, remote 0

MTU: local 9216, remote 9216

Remote interface description:

Sequencing: receive disabled, send disabled

Control Word: Off

SSO Descriptor: 1.1.1.1.6/4, local label: 23

Dataplane:

SSM segment/switch IDs: 8212/8210 (used), PWID: 1

VC statistics:

transit packet totals: receive 7, send 5

transit byte totals:   receive 992, send 642

transit packet drops:  receive 0, seq error 0, send 0

 

PE-2#show mpls l2transport vc detail

Local interface: Gi0/0/1 up, line protocol up, Ethernet up

Destination address: 1.1.1.1.7, VC ID: 4, VC status: up

Output interface: Gi0/0/0, imposed label stack {23}

Preferred path: not configured

Default path: active

Next hop: 10.177.183.3

Create time: 00:48:02, last status change time: 00:01:07

Last label FSM state change time: 00:01:07

Last peer autosense occurred at: 00:01:07

Signaling protocol: LDP, peer 1.1.1.1.7:0 up

Targeted Hello: 1.1.1.1.6(LDP Id) -> 1.1.1.1.7, LDP is UP

Status TLV support (local/remote)   : enabled/supported

LDP route watch                   : enabled

Label/status state machine        : established, LruRru

Last local dataplane   status rcvd: No fault

Last BFD dataplane     status rcvd: Not sent

Last BFD peer monitor  status rcvd: No fault

Last local AC  circuit status rcvd: No fault

Last local AC  circuit status sent: No fault

Last local PW i/f circ status rcvd: No fault

Last local LDP TLV     status sent: No fault

Last remote LDP TLV    status rcvd: No fault

Last remote LDP ADJ    status rcvd: No fault

MPLS VC labels: local 50, remote 23

Group ID: local 0, remote 0

MTU: local 9216, remote 9216

Remote interface description:

Sequencing: receive disabled, send disabled

Control Word: Off (configured: autosense)

SSO Descriptor: 1.1.1.1.7/4, local label: 50

Dataplane:

SSM segment/switch IDs: 4423/4416 (used), PWID: 5

VC statistics:

transit packet totals: receive 26, send 79

transit byte totals:   receive 2644, send 23790

transit packet drops:  receive 0, seq error 0, send 0

 

Sonuç :

S-Vlan ve C-Vlan bilgisi pseudowire üzerinden taşınıyor.Packet capture ilk control word on ikinci olarak control word off kullanım görülüyor. Her iki durumdada C-Vlan Headar ve CoS bilgisi taşınıyor. Control word bilgisi S-Vlan taşınma methodunu belirliyor.

 

Test 4 EFC Frame Work Kullanımı :

Konfigurasyon :

PE-2:

!

interface GigabitEthernet0/0/1

mtu 9216

no ip address

negotiation auto

cdp enable

service instance 1 ethernet

encapsulation dot1q 50

xconnect 1.1.1.1.6 4 encapsulation mpls pw-class test

!

!

PE-3:

interface GigabitEthernet0/0/1

mtu 9216

no ip address

negotiation auto

service instance 1 ethernet

encapsulation dot1q 50

xconnect 1.1.1.1.7 4 encapsulation mpls

!

Kontrol :

PE-3#show mpls l2transport vc detail

Local interface: Gi0/0/1 up, line protocol up, Eth VLAN 50 up

Interworking type is Ethernet

Destination address: 1.1.1.1.6, VC ID: 4, VC status: up

Output interface: Gi0/0/0, imposed label stack {75}

Preferred path: not configured

Default path: active

Next hop: 10.177.183.2

Create time: 00:21:03, last status change time: 00:01:41

Last label FSM state change time: 00:01:41

Signaling protocol: LDP, peer 1.1.1.1.6:0 up

Targeted Hello: 1.1.1.1.7(LDP Id) -> 1.1.1.1.6, LDP is UP

Status TLV support (local/remote)   : enabled/supported

LDP route watch                   : enabled

Label/status state machine        : established, LruRru

Last local dataplane   status rcvd: No fault

Last BFD dataplane     status rcvd: Not sent

Last BFD peer monitor  status rcvd: No fault

Last local AC  circuit status rcvd: No fault

Last local AC  circuit status sent: No fault

Last local PW i/f circ status rcvd: No fault

Last local LDP TLV     status sent: No fault

Last remote LDP TLV    status rcvd: No fault

Last remote LDP ADJ    status rcvd: No fault

MPLS VC labels: local 20, remote 75

Group ID: local 0, remote 0

MTU: local 9216, remote 9216

Remote interface description:

Sequencing: receive disabled, send disabled

Control Word: On

SSO Descriptor: 1.1.1.1.6/4, local label: 20

Dataplane:

SSM segment/switch IDs: 4125/8216 (used), PWID: 1

VC statistics:

transit packet totals: receive 26, send 38

transit byte totals:   receive 2940, send 5112

transit packet drops:  receive 21, seq error 0, send 0

 

Control word kapalı:

PE-3:

pseudowire-class test

encapsulation mpls

no control-word

 

PE-3#show mpls l2transport vc detail

Local interface: Gi0/0/1 up, line protocol up, Eth VLAN 50 up

Interworking type is Ethernet

Destination address: 1.1.1.1.6, VC ID: 4, VC status: up

Output interface: Gi0/0/0, imposed label stack {45}

Preferred path: not configured

Default path: active

Next hop: 10.177.183.2

Create time: 00:00:42, last status change time: 00:00:31

Last label FSM state change time: 00:00:31

Last peer autosense occurred at: 00:00:37

Signaling protocol: LDP, peer 1.1.1.1.6:0 up

Targeted Hello: 1.1.1.1.7(LDP Id) -> 1.1.1.1.6, LDP is UP

Status TLV support (local/remote)   : enabled/supported

LDP route watch                   : enabled

Label/status state machine        : established, LruRru

Last local dataplane   status rcvd: No fault

Last BFD dataplane     status rcvd: Not sent

Last BFD peer monitor  status rcvd: No fault

Last local AC  circuit status rcvd: No fault

Last local AC  circuit status sent: No fault

Last local PW i/f circ status rcvd: No fault

Last local LDP TLV     status sent: No fault

Last remote LDP TLV    status rcvd: No fault

Last remote LDP ADJ    status rcvd: No fault

MPLS VC labels: local 22, remote 45

Group ID: local 0, remote 0

MTU: local 9216, remote 9216

Remote interface description:

Sequencing: receive disabled, send disabled

  Control Word: Off

SSO Descriptor: 1.1.1.1.6/4, local label: 22

Dataplane:

SSM segment/switch IDs: 8224/4126 (used), PWID: 1

VC statistics:

transit packet totals: receive 2, send 2

transit byte totals:   receive 244, send 280

transit packet drops:  receive 0, seq error 0, send 0

 

Sonuç :

Control  Word kullanılsın veya kullanılmasın S-Vlan ve C-Vlan karşıya iletiliyor.  Eğer yaratılan service instance içerisinde rewrite ingress tag pop 1 symetric komutu kullanılsa idi, S-Vlan bilgisi karşıya taşınmıyacakdı.

 

Test  5 Ethernet port mode ve vlan mode birlikte kullanımı :

Konfigurayon :

Eğer Vlan tarafında service instance kullanılmaz ise

PE-2:

!

interface GigabitEthernet0/0/1

mtu 9216

no ip address

negotiation auto

xconnect 1.1.1.1.6 4 encapsulation mpls

!

PE-3 :

pseudowire-class test

encapsulation mpls

!

 

interface GigabitEthernet0/0/1

mtu 9216

no ip address

negotiation auto

!

interface GigabitEthernet0/0/1.50

encapsulation dot1Q 50

xconnect 1.1.1.1.6 4 encapsulation mpls pw-class test

!

Bu durumda karşı tarafı PE-3’den PE-2 S vlan taşınmaz dolayısı ile erişim olmaz. S vlanı taşımanın tek yolu PE-3’de ya port moda yada service instance kullanmakdır. Port mod kullanılır ise zaten port moda port mod olur.

 

Bu test’de service instance kullanımını denedik.

Kontrol :

PE-3#show mpls l2transport vc detail

Local interface: Gi0/0/1 up, line protocol up, Eth VLAN 50 up

Interworking type is Ethernet

Destination address: 1.1.1.1.6, VC ID: 4, VC status: up

Output interface: Gi0/0/0, imposed label stack {43}

Preferred path: not configured

Default path: active

Next hop: 10.177.183.2

Create time: 00:00:04, last status change time: 00:00:04

Last label FSM state change time: 00:00:04

Signaling protocol: LDP, peer 1.1.1.1.6:0 up

Targeted Hello: 1.1.1.1.7(LDP Id) -> 1.1.1.1.6, LDP is UP

Status TLV support (local/remote)   : enabled/supported

LDP route watch                   : enabled

Label/status state machine        : established, LruRru

Last local dataplane   status rcvd: No fault

Last BFD dataplane     status rcvd: Not sent

Last BFD peer monitor  status rcvd: No fault

Last local AC  circuit status rcvd: No fault

Last local AC  circuit status sent: No fault

Last local PW i/f circ status rcvd: No fault

Last local LDP TLV     status sent: No fault

Last remote LDP TLV    status rcvd: No fault

Last remote LDP ADJ    status rcvd: No fault

MPLS VC labels: local 17, remote 43

Group ID: local 0, remote 0

MTU: local 9216, remote 9216

Remote interface description:

Sequencing: receive disabled, send disabled

Control Word: Off

SSO Descriptor: 1.1.1.1.6/4, local label: 17

Dataplane:

SSM segment/switch IDs: 4135/4134 (used), PWID: 1

VC statistics:

transit packet totals: receive 0, send 0

transit byte totals:   receive 0, send 0

transit packet drops:  receive 0, seq error 0, send 0

 

Test 6 : Farklı service vlanlar Kullanımı :

Konfigurayon :

Her iki tarafda vlan modda ise sorun yok. ASR’da port modda kullanmanın bir anlamı yok. ASR bir S-Vlanı ile gelmiş olması gerek zaten.

 

ASR’da QiQ yapmak için  :

interface GigabitEthernet0/0/1

mtu 9216

no ip address

negotiation auto

cdp enable

service instance 1 ethernet

encapsulation dot1q 1-4094

rewrite ingress tag push dot1q 50 symmetric

xconnect 1.1.1.1.7 4 encapsulation mpls

!

 

kullanılabilir.

 

Her iki tarafda Vlan modda ise nasıl S-Vlanlar farklı olabilir?Subinterface ile S-Vlan’ın onemi yok zira karşıya taşınmıyor!

 

PE-2 :

interface GigabitEthernet0/0/1.60

encapsulation dot1Q 60

xconnect 1.1.1.1.7 4 encapsulation mpls

!

interface GigabitEthernet0/0/2

no ip address

negotiation auto

cdp enable

!

interface GigabitEthernet0/0/2.50

encapsulation dot1Q 60 second-dot1q 200

ip vrf forwarding test

ip

PE-3 :

interface GigabitEthernet0/0/1

mtu 9216

no ip address

negotiation auto

!

interface GigabitEthernet0/0/1.50

encapsulation dot1Q 50

xconnect 1.1.1.1.6 4 encapsulation mpls pw-class test

 

Kontrol :

PE-3#show mpls l2transport vc  detail

Local interface: Gi0/0/1.50 up, line protocol up, Eth VLAN 50 up

Interworking type is Ethernet

Destination address: 1.1.1.1.6, VC ID: 4, VC status: up

Output interface: Gi0/0/0, imposed label stack {36}

Preferred path: not configured

Default path: active

Next hop: 10.177.183.2

Create time: 00:00:51, last status change time: 00:00:08

Last label FSM state change time: 00:00:10

Signaling protocol: LDP, peer 1.1.1.1.6:0 up

Targeted Hello: 1.1.1.1.7(LDP Id) -> 1.1.1.1.6, LDP is UP

Status TLV support (local/remote)   : enabled/supported

LDP route watch                   : enabled

Label/status state machine        : established, LruRru

Last local dataplane   status rcvd: No fault

Last BFD dataplane     status rcvd: Not sent

Last BFD peer monitor  status rcvd: No fault

Last local AC  circuit status rcvd: No fault

Last local AC  circuit status sent: No fault

Last local PW i/f circ status rcvd: No fault

Last local LDP TLV     status sent: No fault

Last remote LDP TLV    status rcvd: No fault

Last remote LDP ADJ    status rcvd: No fault

MPLS VC labels: local 20, remote 36

Group ID: local 0, remote 0

MTU: local 9216, remote 9216

Remote interface description:

Sequencing: receive disabled, send disabled

Control Word: On (configured: autosense)

SSO Descriptor: 1.1.1.1.6/4, local label: 20

Dataplane:

SSM segment/switch IDs: 4161/8254 (used), PWID: 1

VC statistics:

transit packet totals: receive 0, send 0

transit byte totals:   receive 0, send 0

transit packet drops:  receive 0, seq error 0, send 0

 

PE-3#ping vrf test 5.5.5.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 5.5.5.2, timeout is 2 seconds:

.!!!!

Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/1 ms

PE-3#

 

Sonuç :

Packet capture’da bu durum gorulebilir. Sadece C vlan taşınıyor.

 

Test 7  Service instance farklı S-Vlan kullanımı

Konfigurasyon :

PE-2 :

interface GigabitEthernet0/0/1

mtu 9216

no ip address

negotiation auto

cdp enable

service instance 1 ethernet

encapsulation dot1q 60

xconnect 1.1.1.1.7 4 encapsulation mpls

!

!

PE-3 :

pseudowire-class test

encapsulation mpls

!

!

interface GigabitEthernet0/0/1

mtu 9216

no ip address

negotiation auto

service instance 1 ethernet

encapsulation dot1q 50

xconnect 1.1.1.1.6 4 encapsulation mpls pw-class test

!

!

Kontrol :

PE-3#show mpls l2transport vc  detail

Local interface: Gi0/0/1 up, line protocol up, Eth VLAN 50 up

Interworking type is Ethernet

Destination address: 1.1.1.1.6, VC ID: 4, VC status: up

Output interface: Gi0/0/0, imposed label stack {34}

Preferred path: not configured

Default path: active

Next hop: 10.177.183.2

Create time: 00:02:17, last status change time: 00:01:27

Last label FSM state change time: 00:01:27

Signaling protocol: LDP, peer 1.1.1.1.6:0 up

Targeted Hello: 1.1.1.1.7(LDP Id) -> 1.1.1.1.6, LDP is UP

Status TLV support (local/remote)   : enabled/supported

LDP route watch                   : enabled

Label/status state machine        : established, LruRru

Last local dataplane   status rcvd: No fault

Last BFD dataplane     status rcvd: Not sent

Last BFD peer monitor  status rcvd: No fault

Last local AC  circuit status rcvd: No fault

Last local AC  circuit status sent: No fault

Last local PW i/f circ status rcvd: No fault

Last local LDP TLV     status sent: No fault

Last remote LDP TLV    status rcvd: No fault

Last remote LDP ADJ    status rcvd: No fault

MPLS VC labels: local 22, remote 34

Group ID: local 0, remote 0

MTU: local 9216, remote 9216

Remote interface description:

Sequencing: receive disabled, send disabled

Control Word: On (configured: autosense)

SSO Descriptor: 1.1.1.1.6/4, local label: 22

Dataplane:

SSM segment/switch IDs: 4165/4162 (used), PWID: 1

VC statistics:

transit packet totals: receive 0, send 5

transit byte totals:   receive 0, send 720

transit packet drops:  receive 0, seq error 0, send 0

PE-3#ping vrf test 5.5.5.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 5.5.5.2, timeout is 2 seconds:

…..

Success rate is 0 percent (0/5)

PE-3#

 

Sonuç :

Packet capture goruleceği gibi S vlan ve C vlan beraber iletiyliyor. Dolayısı ile karşı tarafdaki S vlan ile eşleşmiyor.

 

Bunun için her iki tarafdada S vlanlar pop edilmelidir.

 

PE-3 :

interface GigabitEthernet0/0/1

mtu 9216

no ip address

negotiation auto

service instance 1 ethernet

encapsulation dot1q 50

rewrite ingress tag pop 1 symmetric

xconnect 1.1.1.1.6 4 encapsulation mpls pw-class test

!

PE-2 :

interface GigabitEthernet0/0/1

mtu 9216

no ip address

negotiation auto

cdp enable

service instance 1 ethernet

encapsulation dot1q 60

xconnect 1.1.1.1.7 4 encapsulation mpls

!

 

 

 

ME 3600 ve Ethernet over MPLS kullanımı :

 

Test 1 PE tarafında subinterface tanımı kullanmak :

PE-2 tarafında devre subinterface ile alınır ise, ilk vlan tag S vlan encapsulation komutu ile interface’den giderken eklenir ve pseudowire gonderilirken çıkartılır.

3600NNI tani EVC kullanılan tarafda ise herhangi bir rewrite işlemi yapılmaz ise paketler geldikleri gibi gönderilir.

p2p_l2mpls_3600_test_toplogy_1

 

 

 

 

 

 

 

 

3600NNI tarafında service vlan’ı pseudowire aktarılır iken çıkartıldığı zaman sorun çözülmüş olur.

 

Bu şekilde iki uçda farklı S-Vlan kullanmakda mümkün olur.

p2p_l2mpls_3600_test_toplogy_2

Test 2 2 Adet S vlan 1 S vlan’a olarak iletmek :

p2p_l2mpls_3600_test_toplogy_3

Leave a Reply