Point to Point EoMPLS, subinterface ve EVC konfigurasyonu arasındaki farklar.

Ön bilgi :

1 – CE tarafından iletilen paket, pseudowire üzerinden iletilmeden önce ethernet frame’den CRC ve preamble alanları çıkartılarak iletilir. Çıkış PE, karşı CE doğru pakedi göndermeden önce, yeni bir CRC değeri hesaplıyarak iletir. Bazı uygulamalarda frame-seq ve CRC değişimi sorunlar oluşturabilir. Dolayısı ile control-word kullanımı gerekli olabilir.

2 – Genel olarak, data trafiği tek yönlü olarak düşünülmelidir. Pseudowire üzerinden bir yönde tag trafik var iken, aksi yönde tagsiz trafik olabilir. Giriş yönündeki PE, karşı ucdaki PE’nin pakedi nasıl ileteceğine karışmaz. Bu özellik (tag rewrite, tag remove vb) çıkış yönündeki PE’nin out portundaki tanımlar ile belirlenir. RFC 4448 aslında bu konuda yararlı bilgiler barındırmaktadır.

3 – l2control paketlerinin iletimi, özel konfigurasyon istiyebilir. Bazı cihaz üreticileri default olarak’da l2control paketlerini iletir iken bazıları iletmiyebilir.

4 – Tag rewrite vb işlemler kullanılıyor ise, l2control (STP vb) packetlerinin kullanımında sorunlar olabilir. Buna dikkat edilmelidir. İki tip EoMPLS tipi vardır. Port/Raw mode veya Vlan/Tagged mod. Bu tanımlar giriş, ingress yönünde ki işlevi tanımlar.

1 – Port/Raw Mode ( type 0x0005) : Port’a gelen tüm paketler, tagli veya tagsiz pseudowire üzerinden olduğu gibi iletilir. Burada CE’den gelen tüm paketler, tek bir pseudowire ile eşleştirilip karşı uca gönderilir. Tüm paketler tek bir pseudowire ile eşletirileceği için genelde fiziksel olarak bir port olduğu gibi pseudowire üzerinden iletilir.

2 – Vlan/Tagged Mode ( type 0x0004) : Tagged mode, pakedin giriş PE tarafından tag’li beklendiğini anlatır. Çıkış yönünde ise paket tagli, tagsiz veya tag bilgisi değiştirilerek karşı uçdaki CE’ye iletilebilir. Genelde service vlan (ethernet aggregation veya NNI ) kullanımı durumunda kullanılır. Tek bir portdan farklı gelen paketleri farklı pseudowire ile eşleştirerek, farklı uç noktalara göndermek için kullanılır. Cisco’nun EVC frame work gibi benzeri methodlar ile aslında bu eşleştirme tag bilgisi dışında COS vb ethernet parametreleri ilede yapılabilir. Cisco’da tagged mode subinterface kullanılarak veya EVC frame work kullanılarak gerçekleştirilebilir.

İkisi arasında temel bir fark vardır. Subinterface kullanılması durumunda, subinterface tarafından yakalanan trafik, yakalama şartı tarafından kullanılan vlan bilgileri çıkartılarak pseudowire üzerinden gönderilir. encapsulation dot1q 400 ise 400 vlan’ı, encapsulation dot1q 400 second dot1q 600 ise 400 ve 600 vlan’ı çıkartılarak pseudowire üzerinden gönderilir.

Anlatılmak istenen subinterface konfigurasyonun eğer pseudowire type 5 olarak kurulmuş ise, IOX XE veya IOS vlan taggini atarak gönderiyor.

EoMPLS Tagged Mode With Subinterface
EoMPLS Tagged Mode With Subinterface

EVC kullanımlası durumunda durum tam tersidir. Varsayılan olarak paket tüm vlan bilgilerini içererek pseudowire üzerinden gönderilir. Vlan bilgisini pseudowire üzerinden gönderir iken çıkartmak için rewrite komutu kullanılmalıdır.

EVC frame work için : Building Carrier Ethernet Services Using Cisco Ethernet Virtual Circuit Framework

https://supportforums.cisco.com/docs/DOC-15556

https://supportforums.cisco.com/message/4107321

EoMPLS Tagged Mode with EVC
EoMPLS Tagged Mode with EVC

 

Testler : Pseudowire control word on veya off olmasına göre Cisco’da Pseudowire üzerinden ethernet paketlerinin taşınmasında olan farkı bilmek gerekir. Aslında CE tarafında bir şey değiştirmez fakat pseudowire üzerinde paketlerin iletimini değiştirir. Şöyle ki; Eğer pseudowire üzerinden  tag’li paket iletimini kapsar. Cisco control word off iken, paketi tagged olarak iletmiyor. Source ve Dest mac adresini değiştiriyor. Source mac adresinin son 12 biti vlan bilgisini içeriyor. Bir kısım bitlerde cos değerini içeriyor. Çıkış PE’si bu bilgileri kullanarak vlan bilgisini tekrar hesaplıyor, fakat gerçek source ve dest mac nasıl hesaplıyor bilemiyorum. Bunun hakkında bir döküman bulamadım.

Test 1.1 Control word off/Port Mode/no tagged: Tagli bir iletim olmadığı için bahsedilen uygulama görülemez. 

CE’lerin mac adreslerine dikkat!

CE-1 :
interface GigabitEthernet0/0/0
ip address 5.5.5.5 255.255.255.0
negotiation auto
end
PE-1 :
interface GigabitEthernet0/0/1
no ip address
negotiation auto
xconnect 192.168.126.4 1 encapsulation mpls
end
PE-2 :
interface GigabitEthernet0/11
no switchport
no ip address
xconnect 192.168.126.219 1 encapsulation mpls
end
CE-2 :
interface GigabitEthernet0/0/0
ip address 5.5.5.6 255.255.255.0
negotiation auto
end

CE-1 :
GigabitEthernet0/0/0 is up, line protocol is up
Hardware is 4XGE-BUILT-IN, address is a493.4c52.1100 (bia a493.4c52.1100)
…..
CE-2 :
GigabitEthernet0/0/0 is up, line protocol is up
Hardware is 4XGE-BUILT-IN, address is 0007.7d6a.9b00 (bia 0007.7d6a.9b00)
…..

PE-1 :
sh mpls l2 vc 1 detail
Local interface: Gi0/0/1 up, line protocol up, Ethernet up
Destination address: 192.168.126.4, VC ID: 1, VC status: up
Output interface: Gi0/0/0, imposed label stack {3324 81}
Preferred path: not configured
Default path: active
Next hop: 193.192.119.241
Create time: 00:11:24, last status change time: 00:09:03
Last label FSM state change time: 00:11:18
Last peer autosense occurred at: 00:11:18
Signaling protocol: LDP, peer 192.168.126.4:0 up
Targeted Hello: 192.168.126.219(LDP Id) -> 192.168.126.4, LDP is UP
Graceful restart: not configured and not enabled
Non stop routing: not configured and not enabled
Status TLV support (local/remote) : enabled/supported
LDP route watch : enabled
Label/status state machine : established, LruRru
Last local dataplane status rcvd: No fault
Last BFD dataplane status rcvd: Not sent
Last BFD peer monitor status rcvd: No fault
Last local AC circuit status rcvd: No fault
Last local AC circuit status sent: No fault
Last local PW i/f circ status rcvd: No fault
Last local LDP TLV status sent: No fault
Last remote LDP TLV status rcvd: No fault
Last remote LDP ADJ status rcvd: No fault
MPLS VC labels: local 151, remote 81
Group ID: local 0, remote 0
MTU: local 1500, remote 1500
Remote interface description:
Sequencing: receive disabled, send disabled
Control Word: Off (configured: autosense)
SSO Descriptor: 192.168.126.4/1, local label: 151
Dataplane:
SSM segment/switch IDs: 8229/4131 (used), PWID: 1
VC statistics:
transit packet totals: receive 18, send 9
transit byte totals: receive 1757, send 979
transit packet drops: receive 0, seq error 0, send 0

 

Test 1.2 Control word off/Port Mode/tagged:

CE’lerin mac adreslerine dikkat!

Sadece CE konfigleri değiştirildi.
CE-1 :
interface GigabitEthernet0/0/0
no ip address
negotiation auto
interface GigabitEthernet0/0/0.400
encapsulation dot1Q 400
ip address 5.5.5.5 255.255.255.0
CE-2 :
interface GigabitEthernet0/0/0
no ip address
negotiation auto
interface GigabitEthernet0/0/0.400
encapsulation dot1Q 400
ip address 5.5.5.6 255.255.255.0

PE-2 :
Local interface: Gi0/0/1 up, line protocol up, Ethernet up
Destination address: 192.168.126.4, VC ID: 1, VC status: up
Output interface: Gi0/0/0, imposed label stack {3324 81}
Preferred path: not configured
Default path: active
Next hop: 193.192.119.241
Create time: 00:19:29, last status change time: 00:03:15
Last label FSM state change time: 00:03:17
Last peer autosense occurred at: 00:19:23
Signaling protocol: LDP, peer 192.168.126.4:0 up
Targeted Hello: 192.168.126.219(LDP Id) -> 192.168.126.4, LDP is UP
Graceful restart: not configured and not enabled
Non stop routing: not configured and not enabled
Status TLV support (local/remote) : enabled/supported
LDP route watch : enabled
Label/status state machine : established, LruRru
Last local dataplane status rcvd: No fault
Last BFD dataplane status rcvd: Not sent
Last BFD peer monitor status rcvd: No fault
Last local AC circuit status rcvd: No fault
Last local AC circuit status sent: No fault
Last local PW i/f circ status rcvd: No fault
Last local LDP TLV status sent: No fault
Last remote LDP TLV status rcvd: No fault
Last remote LDP ADJ status rcvd: No fault
MPLS VC labels: local 154, remote 81
Group ID: local 0, remote 0
MTU: local 1500, remote 1500
Remote interface description:
Sequencing: receive disabled, send disabled
Control Word: Off (configured: autosense)
SSO Descriptor: 192.168.126.4/1, local label: 154
Dataplane:
SSM segment/switch IDs: 8231/4131 (used), PWID: 1
VC statistics:
transit packet totals: receive 38, send 23
transit byte totals: receive 4245, send 2600
transit packet drops: receive 0, seq error 0, send 0

TEST 1.2 source and destination mac address change on pseudowire with control word
TEST 1.2 source and destination mac address change on pseudowire with control word

Test 1.3 Control word on/Port Mode/tagged:

CE-1 :
interface GigabitEthernet0/0/0
no ip address
negotiation auto
interface GigabitEthernet0/0/0.400
encapsulation dot1Q 400
ip address 5.5.5.5 255.255.255.0

PE-1
pseudowire-class test
encapsulation mpls

interface GigabitEthernet0/0/1
no ip address
negotiation auto
xconnect 192.168.126.4 1 encapsulation mpls pw-class test
end
PE-2
pseudowire-class test
encapsulation mpls
control-word

interface GigabitEthernet0/11
no switchport
no ip address
xconnect 192.168.126.219 1 encapsulation mpls pw-class test
end

CE-2 :
interface GigabitEthernet0/0/0
no ip address
negotiation auto
interface GigabitEthernet0/0/0.400
encapsulation dot1Q 400
ip address 5.5.5.6 255.255.255.0

PE-1 :
Local interface: Gi0/0/1 up, line protocol up, Ethernet up
Destination address: 192.168.126.4, VC ID: 1, VC status: up
Output interface: Gi0/0/0, imposed label stack {3324 191}
Preferred path: not configured
Default path: active
Next hop: 193.192.119.241
Create time: 00:03:55, last status change time: 00:03:19
Last label FSM state change time: 00:03:21
Signaling protocol: LDP, peer 192.168.126.4:0 up
Targeted Hello: 192.168.126.219(LDP Id) -> 192.168.126.4, LDP is UP
Graceful restart: not configured and not enabled
Non stop routing: not configured and not enabled
Status TLV support (local/remote) : enabled/supported
LDP route watch : enabled
Label/status state machine : established, LruRru
Last local dataplane status rcvd: No fault
Last BFD dataplane status rcvd: Not sent
Last BFD peer monitor status rcvd: No fault
Last local AC circuit status rcvd: No fault
Last local AC circuit status sent: No fault
Last local PW i/f circ status rcvd: No fault
Last local LDP TLV status sent: No fault
Last remote LDP TLV status rcvd: No fault
Last remote LDP ADJ status rcvd: No fault
MPLS VC labels: local 155, remote 191
Group ID: local 0, remote 0
MTU: local 1500, remote 1500
Remote interface description:
Sequencing: receive disabled, send disabled
Control Word: On (configured: autosense)
SSO Descriptor: 192.168.126.4/1, local label: 155
Dataplane:
SSM segment/switch IDs: 4138/8232 (used), PWID: 1
VC statistics:
transit packet totals: receive 9, send 7
transit byte totals: receive 1192, send 859
transit packet drops: receive 0, seq error 0, send 0

TEST 1.3 Source and destination mac address with control word
TEST 1.3 Source and destination mac address with control word

Test 1.4 Control word off/Port Mode/double tagged: İkinci vlan bilgisi gözüküyor. İlk vlan bilgisi ise bahsedilen mac address değiştirme methodu ile bir şekilde karşıya iletiliyor.

CE-1 :
interface GigabitEthernet0/0/0
no ip address
negotiation auto
interface GigabitEthernet0/0/0.400 second-dot1q 600
encapsulation dot1Q 400
ip address 5.5.5.5 255.255.255.0
CE-2 :
interface GigabitEthernet0/0/0
no ip address
negotiation auto
interface GigabitEthernet0/0/0.400 second-dot1q 600
encapsulation dot1Q 400
ip address 5.5.5.6 255.255.255.0
PE-1 :
interface GigabitEthernet0/0/1
no ip address
negotiation auto
xconnect 192.168.126.4 1 encapsulation mpls
end
PE-2 :
interface GigabitEthernet0/11
no switchport
no ip address
xconnect 192.168.126.219 1 encapsulation mpls
end

 

TEST 1.4 source and destination mac address change on pseudowire with control word
TEST 1.4 source and destination mac address change on pseudowire with control word

Test 2 Port Mode : Port mode kullanımı test edilmişdir. Pakedin tag’siz olması durum Test 1.1 ile aynıdır.

Test 2.1 Port Mode/double tagged/ :

EoMPLS Port Mode
EoMPLS Port Mode

 

CE-1 :
interface GigabitEthernet0/0/0
no ip address
negotiation auto
interface GigabitEthernet0/0/0.400 second-dot1q 600
encapsulation dot1Q 400
ip address 5.5.5.5 255.255.255.0
CE-2 :
interface GigabitEthernet0/0/0
no ip address
negotiation auto
interface GigabitEthernet0/0/0.400 second-dot1q 600
encapsulation dot1Q 400
ip address 5.5.5.6 255.255.255.0
PE-1 :
interface GigabitEthernet0/0/1
no ip address
negotiation auto
xconnect 192.168.126.4 1 encapsulation mpls pw-class test
end
PE-2 :
interface GigabitEthernet0/11
no switchport
no ip address
xconnect 192.168.126.219 1 encapsulation mpls pw-class test
end

PE-1 :
show mpls l2transport vc detail
Local interface: Gi0/0/1 up, line protocol up, Ethernet up
Destination address: 192.168.126.4, VC ID: 1, VC status: up
Output interface: Gi0/0/0, imposed label stack {3324 84}
Preferred path: not configured
Default path: active
Next hop: 193.192.119.241
Create time: 00:01:38, last status change time: 00:01:09
Last label FSM state change time: 00:01:09
Signaling protocol: LDP, peer 192.168.126.4:0 up
Targeted Hello: 192.168.126.219(LDP Id) -> 192.168.126.4, LDP is UP
Graceful restart: not configured and not enabled
Non stop routing: not configured and not enabled
Status TLV support (local/remote) : enabled/supported
LDP route watch : enabled
Label/status state machine : established, LruRru
Last local dataplane status rcvd: No fault
Last BFD dataplane status rcvd: Not sent
Last BFD peer monitor status rcvd: No fault
Last local AC circuit status rcvd: No fault
Last local AC circuit status sent: No fault
Last local PW i/f circ status rcvd: No fault
Last local LDP TLV status sent: No fault
Last remote LDP TLV status rcvd: No fault
Last remote LDP ADJ status rcvd: No fault
MPLS VC labels: local 156, remote 84
Group ID: local 0, remote 0
MTU: local 1500, remote 1500
Remote interface description:
Sequencing: receive disabled, send disabled
Control Word: On (configured: autosense)
SSO Descriptor: 192.168.126.4/1, local label: 156
Dataplane:
SSM segment/switch IDs: 4152/8247 (used), PWID: 1
VC statistics:
transit packet totals: receive 9, send 5
transit byte totals: receive 1224, send 682
transit packet drops: receive 0, seq error 0, send 0

show mpls l2transport vc interface gigabitEthernet 0/11 detail
Local interface: Gi0/11 up, line protocol up, Ethernet up
Destination address: 192.168.126.219, VC ID: 1, VC status: up
Output interface: Gi0/7, imposed label stack {8428 156}
Preferred path: not configured
Default path: active
Next hop: 193.192.99.30
Create time: 00:03:12, last status change time: 00:03:12
Signaling protocol: LDP, peer 192.168.126.219:0 up
Targeted Hello: 192.168.126.4(LDP Id) -> 192.168.126.219, LDP is UP
Status TLV support (local/remote) : enabled/supported
LDP route watch : enabled
Label/status state machine : established, LruRru
Last local dataplane status rcvd: No fault
Last BFD dataplane status rcvd: Not sent
Last local SSS circuit status rcvd: No fault
Last local SSS circuit status sent: No fault
Last local LDP TLV status sent: No fault
Last remote LDP TLV status rcvd: No fault
Last remote LDP ADJ status rcvd: No fault
MPLS VC labels: local 84, remote 156
PWID: 53345
Group ID: local 0, remote 0
MTU: local 1500, remote 1500
Remote interface description:
Sequencing: receive disabled, send disabled
Control Word: On
VC statistics:
transit packet totals: receive 5, send 5
transit byte totals: receive 682, send 572
transit packet drops: receive 0, seq error 0, send 0

Test 2.2 Port Mode/double tagged/ EVC Frame work kullanımı ile : Vlan bilgisi olduğu gibi gönderiliyor (her ikiside) Test 2.1 göre sadece PE-2 konfiği değiştirildi.

PE-1 :
Local interface: Gi0/0/1 up, line protocol up, Ethernet up
Destination address: 192.168.126.4, VC ID: 1, VC status: up
Output interface: Gi0/0/0, imposed label stack {3324 191}
Preferred path: not configured
Default path: active
Next hop: 193.192.119.241
Create time: 00:06:43, last status change time: 00:00:11
Last label FSM state change time: 00:00:13
Signaling protocol: LDP, peer 192.168.126.4:0 up
Targeted Hello: 192.168.126.219(LDP Id) -> 192.168.126.4, LDP is UP
Graceful restart: not configured and not enabled
Non stop routing: not configured and not enabled
Status TLV support (local/remote) : enabled/supported
LDP route watch : enabled
Label/status state machine : established, LruRru
Last local dataplane status rcvd: No fault
Last BFD dataplane status rcvd: Not sent
Last BFD peer monitor status rcvd: No fault
Last local AC circuit status rcvd: No fault
Last local AC circuit status sent: No fault
Last local PW i/f circ status rcvd: No fault
Last local LDP TLV status sent: No fault
Last remote LDP TLV status rcvd: No fault
Last remote LDP ADJ status rcvd: No fault
MPLS VC labels: local 153, remote 191
Group ID: local 0, remote 0
MTU: local 1500, remote 1500
Remote interface description:
Sequencing: receive disabled, send disabled
Control Word: On (configured: autosense)
SSO Descriptor: 192.168.126.4/1, local label: 153
Dataplane:
SSM segment/switch IDs: 4155/8247 (used), PWID: 1
VC statistics:
transit packet totals: receive 9, send 6
transit byte totals: receive 1224, send 772
transit packet drops: receive 0, seq error 0, send 0

PE-2 :
Local interface: Gi0/11 up, line protocol up, Ethernet:1 up
Destination address: 192.168.126.219, VC ID: 1, VC status: up
Output interface: Gi0/7, imposed label stack {8428 153}
Preferred path: not configured
Default path: active
Next hop: 193.192.99.30
Create time: 00:02:02, last status change time: 00:00:41
Signaling protocol: LDP, peer 192.168.126.219:0 up
Targeted Hello: 192.168.126.4(LDP Id) -> 192.168.126.219, LDP is UP
Status TLV support (local/remote) : enabled/supported
LDP route watch : enabled
Label/status state machine : established, LruRru
Last local dataplane status rcvd: No fault
Last BFD dataplane status rcvd: Not sent
Last local SSS circuit status rcvd: No fault
Last local SSS circuit status sent: No fault
Last local LDP TLV status sent: No fault
Last remote LDP TLV status rcvd: No fault
Last remote LDP ADJ status rcvd: No fault
MPLS VC labels: local 191, remote 153
PWID: 53346
Group ID: local 0, remote 0
MTU: local 1500, remote 1500
Remote interface description:
Sequencing: receive disabled, send disabled
Control Word: On
VC statistics:
transit packet totals: receive 1, send 0
transit byte totals: receive 90, send 0
transit packet drops: receive 0, seq error 0, send 0

Test 2.3 Port Mode/double tagged/ EVC Frame work kullanımı ile : Vlan bilgisi olduğu gibi gönderiliyor (her ikiside)

PE-2 :
interface GigabitEthernet0/11
switchport trunk allowed vlan none
switchport mode trunk
service instance 1 ethernet
encapsulation dot1q 1-4094 second dot1q any
xconnect 192.168.126.219 1 encapsulation mpls pw-class test
!
end

EVC matching şartı ne olursa olsun aynı şekilde davranıyor ve match eden tüm vlan bilgisini karşı tarafa gönderiyor.

Test 3 : Vlan mode kullanımı test edildi.

Test 3.1 Vlan Mode/tagged subint + EVC : PE-1 üzerinde subinterface var. PE-2 service instance tanımı var.CE-1, CE-2 aynı konfigurasyonda.

EoMPLS Vlan mode with EVC defination and rewrite ingress tag pop 1 symethric command

PE-2 :

interface GigabitEthernet0/11
switchport trunk allowed vlan none
switchport mode trunk
mtu 9216
speed 100
duplex full
service instance 1 ethernet
encapsulation dot1q 400
rewrite ingress tag pop 1 symmetric
xconnect 192.168.126.219 1 encapsulation mpls pw-class test
!
end

PE-1 :

interface GigabitEthernet0/0/1
mtu 9216
no ip address
negotiation auto
interface GigabitEthernet0/0/1.400
encapsulation dot1Q 400
xconnect 192.168.126.4 1 encapsulation mpls pw-class test

PE-1 :
Local interface: Gi0/0/1.400 up, line protocol up, Eth VLAN 400 up
Interworking type is Ethernet
Destination address: 192.168.126.4, VC ID: 1, VC status: up
Output interface: Gi0/0/0, imposed label stack {3324 81}
Preferred path: not configured
Default path: active
Next hop: 193.192.119.241
Create time: 00:01:21, last status change time: 00:00:04
Last label FSM state change time: 00:00:06
Signaling protocol: LDP, peer 192.168.126.4:0 up
Targeted Hello: 192.168.126.219(LDP Id) -> 192.168.126.4, LDP is UP
Graceful restart: not configured and not enabled
Non stop routing: not configured and not enabled
Status TLV support (local/remote) : enabled/supported
LDP route watch : enabled
Label/status state machine : established, LruRru
Last local dataplane status rcvd: No fault
Last BFD dataplane status rcvd: Not sent
Last BFD peer monitor status rcvd: No fault
Last local AC circuit status rcvd: No fault
Last local AC circuit status sent: No fault
Last local PW i/f circ status rcvd: No fault
Last local LDP TLV status sent: No fault
Last remote LDP TLV status rcvd: No fault
Last remote LDP ADJ status rcvd: No fault
MPLS VC labels: local 41, remote 81
Group ID: local 0, remote 0
MTU: local 9216, remote 9216
Remote interface description:
Sequencing: receive disabled, send disabled
Control Word: On (configured: autosense)
SSO Descriptor: 192.168.126.4/1, local label: 41
Dataplane:
SSM segment/switch IDs: 4164/4161 (used), PWID: 1
VC statistics:
transit packet totals: receive 9, send 6
transit byte totals: receive 1224, send 748
transit packet drops: receive 0, seq error 0, send 0

PE-2 :
sh mpls l2transport vc interface gigabitEthernet 0/11

Local intf Local circuit Dest address VC ID Status
————- ————————– ————— ———- ———-
Gi0/11 Eth VLAN 400 192.168.126.219 1 UP

 

1 – PE-1 subinterface ile eşlenen trafik, encapsulation dot1q .. komutu ile filtrelenen yakalama kriterindeki vlan tagleri çıkartıp pseudowire gönderiyor. Dolayısı ile PE-1 pseudowire üzerinden paketleri 400 vlan kaldırarak gönderiyor.
2- PE-2 rewrite ingress tag pop 1 symmetric komutundan dolayı 1 tagi kaldırıp pseudowire üzerinden gönderiyor.

Test 3.2 Vlan Mode/tagged subint + EVC : PE-1 üzerinde subinterface var. PE-2’de service instance tanımı var.

PE-2 :

interface GigabitEthernet0/11
switchport trunk allowed vlan none
switchport mode trunk
mtu 9216
speed 100
duplex full
service instance 1 ethernet
encapsulation dot1q 400
xconnect 192.168.126.219 1 encapsulation mpls pw-class test
!
end

PE-1 :

interface GigabitEthernet0/0/1
mtu 9216
no ip address
negotiation auto
interface GigabitEthernet0/0/1.400
encapsulation dot1Q 400
xconnect 192.168.126.4 1 encapsulation mpls pw-class test

PE-2
sh mpls l2transport vc interface gigabitEthernet 0/11

Local intf Local circuit Dest address VC ID Status
————- ————————– ————— ———- ———-
Gi0/11 Eth VLAN 400 192.168.126.219 1 UP

PE-1

Local interface: Gi0/0/1.400 up, line protocol up, Eth VLAN 400 up
Interworking type is Ethernet
Destination address: 192.168.126.4, VC ID: 1, VC status: up
Output interface: Gi0/0/0, imposed label stack {3324 81}
Preferred path: not configured
Default path: active
Next hop: 193.192.119.241
Create time: 00:08:24, last status change time: 00:00:37
Last label FSM state change time: 00:00:39
Signaling protocol: LDP, peer 192.168.126.4:0 up
Targeted Hello: 192.168.126.219(LDP Id) -> 192.168.126.4, LDP is UP
Graceful restart: not configured and not enabled
Non stop routing: not configured and not enabled
Status TLV support (local/remote) : enabled/supported
LDP route watch : enabled
Label/status state machine : established, LruRru
Last local dataplane status rcvd: No fault
Last BFD dataplane status rcvd: Not sent
Last BFD peer monitor status rcvd: No fault
Last local AC circuit status rcvd: No fault
Last local AC circuit status sent: No fault
Last local PW i/f circ status rcvd: No fault
Last local LDP TLV status sent: No fault
Last remote LDP TLV status rcvd: No fault
Last remote LDP ADJ status rcvd: No fault
MPLS VC labels: local 153, remote 81
Group ID: local 0, remote 0
MTU: local 9216, remote 9216
Remote interface description:
Sequencing: receive disabled, send disabled
Control Word: On (configured: autosense)
SSO Descriptor: 192.168.126.4/1, local label: 153
Dataplane:
SSM segment/switch IDs: 4165/4161 (used), PWID: 1
VC statistics:
transit packet totals: receive 18, send 12
transit byte totals: receive 2448, send 1496
transit packet drops: receive 0, seq error 0, send 0

Test 3.1’de belirtildiği gibi PE-2 iki tagide gönderecek ve PE-1’de gelen pakedin başına 400 tag’ini ekleyerek CE-1’e gönderecek. CE-1’e giden paket ise 400+400+600 tag’ine sahip olacak dolayısı ile çalışmıyacakdır.

TEST 3.3 Vlan mode with second dot1q matching :

PE-1 iki tagide kaldırıp PE-2 ‘ye gönderecektir. Dolayısı ile iletişim olmayacakdır. İkinci vlan tag bilgisi kaybolur. Ancak PE-2’de EVC eşleştirmesi 2502 + 400 veya 2502+any olacak şekilde yapılıp, pop tag 2 symethric yapılır ise iletişim olacakdır.
CE-2
interface GigabitEthernet0/0/0.400
encapsulation dot1Q 2502 second-dot1q 400
ip address 5.5.5.9 255.255.255.252
end
PE-2
interface GigabitEthernet0/1
switchport trunk allowed vlan none
switchport mode trunk
mtu 9216
service instance 1 ethernet
encapsulation dot1q 2502
rewrite ingress tag pop 1 symmetric
xconnect 192.168.126.219 2 encapsulation mpls pw-class test
!
end
PE-1
interface GigabitEthernet0/0/1.400
encapsulation dot1Q 2502 second-dot1q 400
xconnect 192.168.126.4 1 encapsulation mpls pw-class test
CE-1
interface GigabitEthernet0/0/0.400
encapsulation dot1Q 2502 second-dot1q 400
ip address 5.5.5.9 255.255.255.252
!
PE-1
Local interface: Gi0/0/1.400 up, line protocol up, Eth VLAN 2502/400 up
Interworking type is Ethernet
Destination address: 192.168.126.4, VC ID: 1, VC status: up
Output interface: Gi0/0/0, imposed label stack {3324 78}
Preferred path: not configured
Default path: active
Next hop: 193.192.119.241
Create time: 00:02:03, last status change time: 00:02:00
Last label FSM state change time: 00:02:00
Signaling protocol: LDP, peer 192.168.126.4:0 up
Targeted Hello: 192.168.126.219(LDP Id) -> 192.168.126.4, LDP is UP
Graceful restart: not configured and not enabled
Non stop routing: not configured and not enabled
Status TLV support (local/remote) : enabled/supported
LDP route watch : enabled
Label/status state machine : established, LruRru
Last local dataplane status rcvd: No fault
Last BFD dataplane status rcvd: Not sent
Last BFD peer monitor status rcvd: No fault
Last local AC circuit status rcvd: No fault
Last local AC circuit status sent: No fault
Last local PW i/f circ status rcvd: No fault
Last local LDP TLV status sent: No fault
Last remote LDP TLV status rcvd: No fault
Last remote LDP ADJ status rcvd: No fault
MPLS VC labels: local 41, remote 78
Group ID: local 0, remote 0
MTU: local 9216, remote 9216
Remote interface description:
Sequencing: receive disabled, send disabled
Control Word: On (configured: autosense)
SSO Descriptor: 192.168.126.4/1, local label: 41
Dataplane:
SSM segment/switch IDs: 4178/4175 (used), PWID: 3
VC statistics:
transit packet totals: receive 0, send 5
transit byte totals: receive 0, send 410
transit packet drops: receive 0, seq error 0, send 0

TEST 3.4 Vlan rewrite :

Test 3.2 dogal sonucudur. S vlan bilgisi EVC ve subinterface tarafından gönderilmez.

EoMPLS Vlan rewrite
CE-1
interface GigabitEthernet0/0/0.400
encapsulation dot1Q 666 second-dot1q 400
ip address 5.5.5.9 255.255.255.252
end
PE-1
interface GigabitEthernet0/0/1
mtu 9216
no ip address
negotiation auto
interface GigabitEthernet0/0/1.400
encapsulation dot1Q 666
xconnect 192.168.126.4 1 encapsulation mpls pw-class test
PE-2
interface GigabitEthernet0/1
switchport trunk allowed vlan none
switchport mode trunk
mtu 9216
service instance 1 ethernet
encapsulation dot1q 2502
rewrite ingress tag pop 1 symmetric
xconnect 192.168.126.219 1 encapsulation mpls pw-class test
!
end
interface GigabitEthernet0/0/0.400
encapsulation dot1Q 2502 second-dot1q 400
ip address 5.5.5.10 255.255.255.252
end