LFA, Remote LFA

Only physical interfaces and physical port-channel interfaces are protected. Subinterfaces, tunnels, and virtual interfaces are not protected (http://www.cisco.com/en/US/docs/ios-xml/ios/iproute_isis/configuration/15-s/irs-rmte-lfa-frr.html#GUID-3C5537BF-6FF5-4A7A-A9E1-4ED82AB1280B). 

I guess this is also true for OSPF :). On ASR 1000 (tried just for 1002 and 1004) with igp (OSPF) adjacencies over subinterface, prefixes are not protected (LFA is not working). When I move igp configuration to the main interface, prefiex are protected.

ASR 1000 (1002 ve 1004 için denedim)  IGP, OSPF komşulukları subinterface üzerinden kurulmuş ise prefixler LFA ile korunamıyor. Komşuluğu ana interface üzerine aldığımda ise prefixler korundu. Aslında ISIS için olan anlatımda bunu belirtiyor, sanırım OSPF içinde aynı kısas var.

Aslinda mantikli olanda bu olabilir. LFA yapısını bir üçgen topoliji gibi düşünürsek, anlam kazanıyor. LFA, üçgenin uçlarına yedeklilik sağladığını ve bir uçdan diğer uca olan bağlantının aynı fiziksel interface altındaki subinterface’ler üzerindan yapıldığı düşünülür ise, aslında fiziksel link gittiğinde diger iki uca olan baglantıda gidiyor demektir. Tabi eğer bu subinterfaceler üzerindeki sanal devreler farklı yolları izliyor ise anlamını yitirebilir veya subinterfaceler farklı ana interfaceler altında olabilir bu durumda yine anlamını yitirir. Neden bu şekilde bir sınırlama olduğunu yine tam olarak bulamadım. ASR100 serisi software tabanlı cihazlar, belki bunun ile ilgili bir kısıtlama vardır. Bunun bir bug olduğu bilgisine ulaştım. Hangi IOS XE sürümlerini etkiliyor bilemiyorum.

Yapılandırma (Configuration) : 

PE-1,2 ve 3 üçgen yapıda bağlandılar. PE-1,2 and 3 are connected in triangle configuration.

 

IGP with Subinterface : 

No prefix protection

PE-1 :
!
interface GigabitEthernet0/0/0
no ip address
negotiation auto
!
interface GigabitEthernet0/0/0.117
encapsulation dot1Q 117
ip address 192.168.1.213 255.255.255.252
ip ospf network point-to-point
ip ospf 11111 area 0
mpls ip
mpls traffic-eng tunnels
!
interface GigabitEthernet0/0/1
no ip address
negotiation auto
!
interface GigabitEthernet0/0/1.118
encapsulation dot1Q 118
ip address 192.168.1.153 255.255.255.252
ip ospf network broadcast # Also I have tried P2P, and different srig groups
ip ospf 11111 area 0
mpls ip
mpls traffic-eng tunnels
!

router ospf 11111
router-id 192.168.126.232
fast-reroute per-prefix enable prefix-priority low
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
!

PE-2 :

interface GigabitEthernet0/0/0
mtu 9216
no ip address
negotiation auto
cdp enable
!
interface GigabitEthernet0/0/0.116
encapsulation dot1Q 116
ip address 192.168.1.209 255.255.255.252
ip mtu 1500
ip ospf network point-to-point
ip ospf 11111 area 0
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
!
interface GigabitEthernet0/0/1
no ip address
negotiation auto
!
interface GigabitEthernet0/0/1.118
encapsulation dot1Q 118
ip address 192.168.1.154 255.255.255.252
ip ospf network broadcast # Also I have tried P2P, and different srig groups
ip ospf 11111 area 0
mpls ip
mpls traffic-eng tunnels
!

router ospf 11111
router-id 192.168.126.230
fast-reroute per-prefix enable prefix-priority low
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
!

PE-3 :

interface GigabitEthernet0/0/1
mtu 9216
no ip address
load-interval 30
negotiation auto
cdp enable
!

interface GigabitEthernet0/0/1.116
encapsulation dot1Q 116
ip address 192.168.1.210 255.255.255.252
ip mtu 1500
ip ospf network point-to-point
ip ospf 11111 area 0
mpls ip
mpls traffic-eng tunnels
!
interface GigabitEthernet0/0/1.117
encapsulation dot1Q 117
ip address 192.168.1.214 255.255.255.252
ip mtu 1500
ip ospf network point-to-point
ip ospf 11111 area 0
mpls ip
mpls traffic-eng tunnels
!
router ospf 11111
router-id 192.168.126.131
ispf
nsf ietf
fast-reroute per-prefix enable area 0 prefix-priority low
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
!

PE-2#show ip ospf fast-reroute prefix-summary

OSPF Router with ID (193.192.126.232) (Process ID 12735)
Base Topology (MTID 0)

Area 0:

Interface Protected Primary paths Protected paths Percent protected
All High Low All High Low All High Low
Lo0 Yes 0 0 0 0 0 0 0% 0% 0%
Gi0/0/1.118 No 2 1 1 0 0 0 0% 0% 0%
Gi0/0/0.117 No 155 76 79 0 0 0 0% 0% 0%

Area total: 157 77 80 0 0 0 0% 0% 0%

Process total: 157 77 80 0 0 0 0% 0% 0%

IGP under main physical interface :

After moved the subinterface configuration under to the main interfaces on PE-1 and PE-2

PE-1 :

no interface GigabitEthernet0/0/1.118
interface GigabitEthernet0/0/1
ip address 192.168.1.154 255.255.255.252
ip ospf network broadcast
ip ospf 11111 area 0
negotiation auto
mpls ip
mpls traffic-eng tunnels
end

PE-2 :

no interface GigabitEthernet0/0/1.118
interface GigabitEthernet0/0/1
ip address 192.168.1.153 255.255.255.252
ip ospf network broadcast
ip ospf 11111 area 0
negotiation auto
mpls ip
mpls traffic-eng tunnels
end

 

All prefixes are protected.

PE-2#show ip ospf fast-reroute prefix-summary

OSPF Router with ID (192.168.126.232) (Process ID 11111)
Base Topology (MTID 0)

Area 0:

Interface Protected Primary paths Protected paths Percent protected
All High Low All High Low All High Low
Lo0 Yes 0 0 0 0 0 0 0% 0% 0%
Gi0/0/1 Yes 2 1 1 2 1 1 100% 100% 100%
Gi0/0/0.117 No 155 76 79 0 0 0 0% 0% 0%

Area total: 157 77 80 2 1 1 1% 1% 1%

Process total: 157 77 80 2 1 1 1% 1% 1%

 

Routing Resiliency – Latest Enhancements

Leave a Reply

Your email address will not be published.